Drush 9 ve Drupal 8'i composer'le kurmak

composer logo

composer PHP için acayip bir bağımlılık yöneticisi. Birçok şey bulunabiliyor. Ben de bu yazımda size drush ve Drupal'ı composer'le nasıl kuracağınızı anlatacağım. Kemerlerinizi takın, başlıyoruz.

Öncelikle işe composer kurarak başlıyoruz. composer kurmak için buraya bakabilirsiniz.

composer ile Drupal kurmanın birkaç tane yolu var, ancak en kolayından bahsedeceğim.

composer create-project drupal-composer/drupal-project:8.x-dev  --stability dev --no-interaction

Daha sonra dizinAdi dizinine girerek composer install yazmanız gerekiyor. Bu Drupal 8 için gerekli.

Bu komut bize Drupal'ın en son sürümünü (şu anda 8.4.0) indiriyor. composer ile normalde Drupal 7 kurulamıyor, ancak onun da bir yolu var. Onu da başka bir yazıda anlatacağım.

Gelelim drush kurmaya.. Onu da şu komutla yapıyoruz:

composer require drush/drush

Bu komut ise bize Drush'ın en son sürümünü (şu anda 9) indiriyor. Eğer belirli sürümünü (8 gibi) istersek onu da şu şekilde duruyoruz:

composer require drush/drush:8

Eklemek ya da düzeltmek istediğiniz bir şey mi var? Yorumlarda belirtin.

Etiketler